采集某个站点的内容,首先学习获取列表,超级列表框

更新时间:2020年05月14日 20:35:36
人气:131
分类: 易语言

采集某个站点的内容,首先学习获取列表,超级列表框,首先来分析站点,以下为分析源站点内容,方便下一步采集到数据库中。

.版本 2
.支持库 iext

.子程序 打开分页列表
.局部变量 i, 整数型
.局部变量 临时表项, 整数型


临时文本 = 访问网页 (“http://www.tianxinqiu.cn/index.php?type=index&page=” + 到文本 (页数))

.如果真 (页数 = 1)
    总页数 = 到数值 (取指定内容 (临时文本, “>1/”, “<”))
    .计次循环首 (总页数, i)
        组合框1.加入项目 (到文本 (i), )
    .计次循环尾 ()
.如果真结束
超级列表框1.全部删除 ()
正则.创建 (#常量2, 临时文本, )
.计次循环首 (正则.取匹配数量 (), i)
    临时表项 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (临时表项, 0, 正则.取子匹配文本 (i, 1))
    超级列表框1.置标题 (临时表项, 1, 正则.取子匹配文本 (i, 2))
    超级列表框1.置标题 (临时表项, 2, 正则.取子匹配文本 (i, 4))
    超级列表框1.置标题 (临时表项, 3, 正则.取子匹配文本 (i, 5))
    超级列表框1.置标题 (临时表项, 4, 正则.取子匹配文本 (i, 6))
    超级列表框1.置标题 (临时表项, 5, 正则.取子匹配文本 (i, 7))
    处理事件 ()
.计次循环尾 ()
.版本 2
.支持库 spec
.支持库 iext

.子程序 搜索列表
.局部变量 搜索文本, 文本型
.局部变量 搜索页数, 整数型
.局部变量 i, 整数型
.局部变量 临时表项, 整数型

搜索页数 = 到数值 (组合框2.内容)
.判断开始 (组合框2.内容 = “”)
    搜索文本 = 访问网页 (“http://www.tianxinqiu.cn/search.php?searchkey=” + 编码_URL编码_GBK (编辑框1.内容) + “&page=1”)
.默认
    搜索文本 = 访问网页 (“http://www.tianxinqiu.cn/search.php?searchkey=” + 编码_URL编码_GBK (编辑框1.内容) + “&page=” + 到文本 (搜索页数))
.判断结束
搜索页数 = 到数值 (取指定内容 (搜索文本, “>1/”, “<”))
.如果真 (到数值 (组合框2.内容) ≤ 1)
    .计次循环首 (搜索页数, i)
        组合框2.加入项目 (到文本 (i), )
    .计次循环尾 ()

.如果真结束
调试输出 (搜索文本)
超级列表框1.全部删除 ()
正则.创建 (#常量3, 搜索文本, )
.计次循环首 (正则.取匹配数量 (), i)
    临时表项 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (临时表项, 0, 正则.取子匹配文本 (i, 1))
    超级列表框1.置标题 (临时表项, 1, 正则.取子匹配文本 (i, 2))
    超级列表框1.置标题 (临时表项, 2, 正则.取子匹配文本 (i, 4))
    超级列表框1.置标题 (临时表项, 3, 正则.取子匹配文本 (i, 5))
    超级列表框1.置标题 (临时表项, 4, 正则.取子匹配文本 (i, 6))
    超级列表框1.置标题 (临时表项, 5, 正则.取子匹配文本 (i, 7))
    处理事件 ()
.计次循环尾 ()


【版权声明】

本文仅代表作者观点,不代表本站立场。本文系作者授权发表,未经许可,不得转载。

相关文章
# 在线留言